You are not logged in.

" Who is online? " List

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

There are 12 guests currently Online

Today, 10:10pm

Thread: "Irrigation Boxes Keep Flooding - Why?"

Today, 10:10pm

Thread: "Zone gradually loses pressure"

Today, 10:10pm

Forum: "Not Sure What's Wrong?"

Today, 10:09pm

Thread: "What size pipe for hookup to main line coming into house"

Today, 10:09pm

Post in thread: "Loosing prime???"

Today, 10:04pm

Add post to thread: "Sprinklers won't work at all"

Today, 10:03pm

Add post to thread: "last sprinkler head in line will not work"

Today, 10:02pm

Thread: "Zone gradually loses pressure"

Today, 10:02pm

Add post to thread: "No stations coming on"

Today, 10:00pm

Add post to thread: "It works when it wants to . . ."

Today, 10:00pm

Thread: "Burst Pipe??"

Today, 9:58pm

Add post to thread: "Control shows no Power"

There are 4 search engine robots currently online (Enable details)

Majestics MJ12bot (10x)

Today, 10:10pm

Add post to thread: "Toro TMC 212 Sprinkler Station Only Turns On Manually By Valve"

abot (4x)

Today, 10:08pm

Post in thread: "Leaking sprinkler head"

Yandex

Today, 10:08pm

Post in thread: "two zones running same time"

Google (3x)

Today, 10:06pm

Thread: "One zone loses pressure?"