You are not logged in.

" Who is online? " List

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

There are 18 guests currently Online

Today, 10:32pm

Forum: "Not Sure What's Wrong?"

Today, 10:30pm

Post in thread: "Electrical Ghost"

Today, 10:29pm

Add post to thread: "Stays on only 1 of 4 zones"

Today, 10:28pm

Post in thread: "Electrical Surging"

Today, 10:27pm

Post in thread: "Zones leaking a small amount of water constantly from last rotor head in line?"

Today, 10:27pm

Post in thread: "Backflow is ..... "backflowing"??"

Today, 10:26pm

Add post to thread: "pump relay/controller/valve issues?"

Today, 10:26pm

Post in thread: "zones run in test, not when programmed"

Today, 10:26pm

Add post to thread: "Sprinkler will not turn on"

Today, 10:25pm

Add post to thread: "Pipes banging when sprinklers are on"

Today, 10:24pm

Add post to thread: "To much water pressure and the zones will not switch on..."

Today, 10:24pm

Add post to thread: "Same Zone comes on everytime"

Today, 10:23pm

Post in thread: "Ancient Non-functioning Imperial Valet Timer Making A Noise."

Today, 10:23pm

Thread: "Email"

Today, 10:22pm

Add post to thread: "ADJUSTING PRESSURE SWITCH"

Today, 10:21pm

Post in thread: "Timing"

Today, 10:19pm

Add post to thread: "Cannot operate system in auto mode"

Today, 10:18pm

Forum: "Not Sure What's Wrong?"

There are 2 search engine robots currently online (Enable details)