You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


New Member


Thursday, June 3rd 2004, 10:40am

Backflow spewing

Hi all. Let me introduce myself first. My name is Ken and I live in Minneola, FL. I've been having a few issues with my sprinkler system. Surprise. Luckily enough I have been able to fix them. However this one has me stumped. I was outside earlier and looked out back to see my backflow spewing water high into the air. I took some pics and wrote a few notes hoping someone could help me out. The pics are all 30k -40k. Could a few of you kindly take a look at what I'm talking about.
I appreciate it.

I turned both valves off at one point then back on and it is still spewing water at a high velocity. It just doesn't quit, ha-ha.

Thanks again,



Advanced Member

Posts: 229

Location: USA


Thursday, June 3rd 2004, 11:07am

Your backflow is shot! You can get a rebuild kit from a plumbing supply and reinsert the guts right at the top of that bonnet. It looks like you bonnete top went also which then you would probably want to just replace the whole backflow. How old is it?


New Member


Thursday, June 3rd 2004, 1:26pm

The system is only one year and 6 months old. What would make this sort of thing happen? I wonder how the guts got all messed up? I have the Watts version and I see sprinkler warehouse has those for sale.

I don't think this, is supposed to be in two pieces is it? Looks like it came right apart. To get this I unscrewed the bonnet (I am assuming that's what that was) from the pipe. The bottom part was down inside and the top part (the prongy one) was in the bonnet. Is this white piece the Vent Float and is it possible to just buy this piece and the Vent Seal. Sure would make it easier. Sorry for all the questions.

Thanks for the reply.



Supreme Member


Thursday, June 3rd 2004, 3:21pm

your pvb most likely froze over the winter. A replacement kit is the way to go. I'd get the poppett (vent float in your case) and the bonnett.


New Member


Thursday, June 3rd 2004, 3:46pm

Well, Tom I would go for that except I'm in central florida. :-) We didn't get too big of a freeze this year. Where is the best place to get a replacement kit by the way.



Supreme Member


Friday, June 4th 2004, 4:21am

Ken, It only takes one night for the water in the PVB to freeze and destroy the insides. Are you saying that there was NEVER a single night when the temperatures didn't dip below freezing there in Florida?


New Member


Friday, June 4th 2004, 4:34am

Well, I can't exactly say that. It would have been back in December or January. I can barely remember 2 days ago, ha-ha.

I have found which replacement kits I need. I got the vent float and the bonnet assembly kit. Ordered from a place called Ewins.

Thanks again.

Rate this thread