You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Starting Member


Friday, August 31st 2012, 4:58pm

Water Pump Not working

Hey all,
I am using a water pump to pressurize secondary irrigation water in order to water my lawn. My ex hubby and friend installed everythnig last spring (2011), and it worked well. It is a Centrifugal Pump, not sure on HP, with a SmartBox being used as the start relay, and a pressure valve used to turn off the pump if the pressure is too low.
This spring the pump did not start up, my(at the time hubby) disassembled it and noticed there was a lot of rust and that the brushes were not able to make a connection. He did whatever it is he did to it and reinstalled, and it's worked great all summer.
It did not come on this past monday. I tried to manually turn on zones, but the pump will not kick on. I hooked it back up to the cullinary water and the that works ok.
The pump is on it's own breaker and it has not flipped the breaker. It appears there is power getting to the relay box, only deduced because, as I turn on a zone from the sprinkler control, the SmartBox makes a soft "bang" noise. Not super scientific, but thought it was a good guess. I'm not sure if there is power getting to the pump, or if the pump is the component having the issue.
I had a guy come out to diagnose the problem, and he wants to start by replacing the SmartBox and see if that fixes it. Seems like there should be a way to diagnose the electrical to see if the pump is getting power. I wanted to hotwire the pump to see if it would kick on, but he said that would blow the pump? I'm not really comfortable with "just replacing" stuff as the diagnosis method :huh:
Any help in trouble shooting this would be greatly appreciated.

Similar threads

Rate this thread