You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Alabama

Starting Member

1

Sunday, June 24th 2012, 3:26pm

Signature (Nelson) Valve Replacement

A Nelson Valve in one zone started failing, leaving the zone on all the time and was replaced 2 years ago. The same zone failed again last year in the same way and I replaced it with a Signature 9501 series valve. That valve is again failing in the same way (zone on part way all the time). I'm beginning to think I installed the valve backwards. The valves aren't marked with an inlet our outlet marking or flow arrow of any sort. Can anyone explain which side is the inlet? Is the side nearest the solenoid the inlet or the outlet?



Thanks for any help. This thing is driving me crazy.



Mark

wsommariva

Supreme Member

Posts: 332

Location: Northern New Jersey

2

Sunday, June 24th 2012, 5:35pm

For both my Hunter and Toro valves the outlet is below the solinoid.

wsommariva

Supreme Member

Posts: 332

Location: Northern New Jersey

3

Sunday, June 24th 2012, 5:38pm

The pros here will know.

mrfixit

Moderator

Posts: 1,417

Location: USA

4

Sunday, June 24th 2012, 6:19pm

We don't have those valves where I come from but I believe it's similar to this valve.
Note the arrow indicating the outlet port on the solenoid side.

5

Monday, June 25th 2012, 8:41am

I just dissembled a 9501 and can't find a flow indicator anywhere. No arrow.
Looking at the build I'd say the outlet is under the solenoid.
The 9000 series and the 7900 series both have outlets under solenoid.
Couldn't find anything on the Signature site.

Rate this thread