You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

wth1405

Unregistered

1

Monday, November 15th 2010, 5:26pm

Busted back flow valve

We bought our house in October '09, at the end of watering season in Texas. One day soon after the sprinklers came on and wouldn't shut off (I'm guessing some kind of electrical problem). I shut the ball valve next to the vacuum breaker to turn off the system, and didn't touch it all winter. We did have a freeze over that winter, which is unusual. This past spring, I opened the ball valve to pressure up the system and see if I could fix the original problem. When the valve was opened, the vacuum breaker turned into a geyser. Could the short freeze have damaged the vacuum breaker to cause this? If I replace the vacuum breaker, should I anticipate any other problems?

As an aside, any ideas to why the system wouldn't shut off in the first place (back in '09)?

hi.todd

Supreme Member

Posts: 412

Location: Houston, Texas

2

Tuesday, November 16th 2010, 10:43am

You can usually repair the Backflow device. It is probably a febco 765-1 PVB. I am sure you can get the repair parts. If it is a different model you can still get the parts. It is pretty easy repair.

The valve not shutting off could be a loose solenoid in the valve or debris in the valve preventing it from closing.

Should be pretty easy if you know where the valves are in the field.

:thumbsup:
:thumbup: :thumbsup:

Rate this thread