You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

illinoisjim

Senior Member

1

Tuesday, May 7th 2019, 10:03pm

Rainbird valve turns on with vent screw but not electrically - even with new solenoid

One of my valves stopped working. I checked electrically and everything looked good - zone was drawing the right amount of current same as other zones. The valved opened when the vent screw or solenoid was backed off. Thought it would be an easy fix and replaced the solenoid with a new one. It doesn't work. Is there anything in the valve that would allow it to open when manually activated with leak screw or loosening solenoid but not when solenoid is energized? Or is it likely a electrical issue - electrical all seemed good but I will check it again before I look at the internals of the valve.

mrfixit

Moderator

Posts: 2,367

Location: USA

2

Wednesday, May 8th 2019, 1:08am

Sounds like a bad diaphragm.

illinoisjim

Senior Member

3

Tuesday, May 21st 2019, 9:02am

Replaced the diaphragm and still didn't work. No voltage on solenoid - output channel of controller is bad. Checked this earlier and thought it was ok but perhaps I missed something... Now wondering how it happened. Perhaps there is an intermittent short in the old solenoid? Is that a possible way for them to fail? It seems unlikely and it draws typical amount of current (but it was replaced). System is working (switched that zone to another zone output) but want to understand what happened and avoid this in the future if possible.

Rate this thread