You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Akrowdya78

Starting Member

1

Saturday, May 3rd 2008, 7:10pm

Sprinkler system backflow preventor saga

Last year I decided to install a sprinkler systems at my moms. This system only of 2 zones of hunter srs 4 inch with 5 each zone. Now heres the problem. I didnt get a chance to turn it on last fall because i didnt want to blow the water out.
When I set up the backflow preventor i had the water supply going into the bottom of preventor and out the right side. When I I tried to turn the water on to the backlfow preventor, water was spuing out of the top. So I came on here asking for answers and they said i installed it backwards. So I reveresed the connections and what do you know, it starts doing the same thing. When I looked at the directions program , it showed I was right the first time.
So what should I do?! I feed up with this!Should i go back to the way i had it, then what , how do i get the water from comming out of the top?Does it have something to do with the test cocks? I am using a febco 765. ?(

Wet_Boots

Supreme Member

Posts: 4,027

Location: Metro NYC

2

Sunday, May 4th 2008, 8:41am

You may need a new bonnet for the 765. You will be surprised at what that little piece of plastic will cost you. Otherwise, you are not following the mfr directions. All PVB devices vent water when first pressurized.

Rate this thread