You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

chri5

Unregistered

1

Thursday, July 5th 2018, 11:07pm

Orbit EasyDial - Voltage dropping from 28v to ~1v after 15-20 seconds

I have an Orbit EasyDial with the following problem.
When I connect a solenoid to it, the solenoid will open fully for approximately 15-20 seconds when the timer is set to come on. Then the solenoid will close while the timer is till running.
I have run a manual cycle with the solenoid disconnected, and my multimeter in place. It held 28V for 4+ minutes.
When I connect a brand new solenoid directly to the irrigation controller, it will fully engage the solenoid. After 15-20 seconds the solenoid no longer has power to keep itself open.
Once the solenoid fails, the controller will be unable to power a solenoid until it is idle for a few minutes. If I turn the controller immediately on again, the voltage isn't enough to power the solenoid.

It seems as if the EasyDial is expending a capacitor to power the solenoid, and isn't able to keep the power supply going for even a minute, much less the forty that it should run.
This problem began recently, and seems to have gotten worse as time has passed.
Any thoughts on making this work besides buying a replacement?

Similar threads

Rate this thread