You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, May 16th 2018, 5:13pm

Irritrol 2500 not shutting off

I am a service tech and have come across a system with all irritrol mt2500 solenoids. It’s about 2 years old. It was a diy install and has good parts but poor workmanship. The master valve and one station valve have slow internal leaks. I opened them up and swapped the diaphragm and seat with a mt2400. This didn’t fix the issue. I noticed that the seat ring is very loose on both. Is this normal?
Has anyone got any experience with these valves or shoul I swap them out for Mt205?

mrfixit

Moderator

Posts: 2,235

Location: USA

2

Wednesday, May 16th 2018, 6:14pm

The 2400 diaphragms wont work in a 2500 valve. The center hole is larger. Will that cause it to leak? I don't think so but it wont work electronically. At least it wouldn't last time I tried it 20 years ago.
I'd make sure there's no debris in the solenoid and make sure the solenoids are snug in the off position.
The seat guide wont cause it to leak either. It could be cracked and it wont leak.
Look closely at the seat for pits. Small ones can be sanded off.
They're excellent valves, no need to swap them out.

3

Friday, May 18th 2018, 8:54pm

I replaced the internals with new, and replaced the coil. Still won’t shut off fully.
Replaced the whole unit with a mt204. Still won’t shut off fully. Not using the controller yet, jut manual on and off. I can get it to shut off by turning the isolation tap off, but when I turn the valve back on it won’t shut down. 350kpa pressure.

mrfixit

Moderator

Posts: 2,235

Location: USA

4

Friday, May 18th 2018, 11:00pm

Is that valve on a drip line?
Try disconnecting the timer wire to that valve. Is the controller sending a partial signal to the valve while the time is off?
Maybe it's time to replace the valve with a 2500.

Rate this thread