You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, October 3rd 2007, 12:59pm

Problem on startup with Febco765

I am in the middle of doing my first irrigation system. I have plumbed all the way to the manifolds and did a test and to flush the water. But when I open up the outlet valve of the PVB, water comes out the top of the fixture. But if the valve is only open 3/4 of the way, no water. Is this a bad check valve? It is brand new, so I am wondering if this is normal.

mrfixit

Moderator

Posts: 1,418

Location: USA

2

Wednesday, October 3rd 2007, 3:57pm

Hi Pen, what you've described is totally normal. There's a float or a poppet inside there that needs the water pressure to seal. So it will leak or flood even til you open the valve up far enough to seal it. No worries.--
--
I'm just clarifying here. Do you mean it leaks when the valve is open all the way or it leaks while you're opening it and it stops leaking at approx 3/4 the way?
If I can't fix it, it's broken!

3

Wednesday, October 3rd 2007, 7:00pm

I think I figured it out. When I initially started the system, I did not have the manifold on because I wanted to flush the pipes. But when I attached the manifold with the valves closed, the PVB did not leak any water. I think it didn't have enough pressure the first time to seal.

Rate this thread