You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Starting Member


Sunday, April 15th 2007, 4:25pm

Trouble shooting Hunter valves?

I installed a sysem on my own last season that has a rainbird controller wired to 2 hunter PGV-100GS valves. The system worked great for about 1 month. Then one of the valves would not open when programmed. If I went out to the box and hand turned the solenoid top, then the valve opens and it would close after programmed amount of time. the second valve worked as programmed. Now, it's time to using the system again, and neither valve will work when I have the controller activate them. What do you think the problem is?? I bought Hunter valves thinking they would work well. Are both solenoids bad? Is there something wrong with my wiring? I followed instructions to a T and used the waterproof grease fittings. Is something wrong with my controller? Any ideas on how to trouble shoot?

Thanks in advance,

Bill Painter

Advanced Member

Posts: 59

Location: Phoenix Az USA


Wednesday, April 18th 2007, 5:50am

That can be a toughie.... first start by checking continuity to the valves and see what the resistance is... at both the clock AND at the solenoids. If there's more than a couple of Ohms difference, I'd start looking at the wire connections. Did you splice the wires between the clock and valves?
Next is the solenoid port. Some valves inherently have critical flow problems in the solenoid chamber (be sure it's clear) and need a "boost" (opening the bleeder or solenoid) when the diaphragm gets stiff when sitting unused. Fr'instance, like when you leave the system off for any extended period of time. Sprinkler systems are like cars... ya can't park 'em and come back weeks or months later and expect them to work perfectly.... every time. Unless you blow your system down for winter, run the valves a minute or two once or twice a week to keep it "lubricated".
The Irrigation Specialist Mfg' Az.
Please check my website and you'll find what I do and the unique tools I make and market.
Real timesavers, especially the Suck-Tube and Krik-It.


Advanced Member


Sunday, April 29th 2007, 6:15pm

just change the valves.


Supreme Member


Monday, April 30th 2007, 3:05am


Sprinkler Solutions, Inc.
Arizona and Colorado


Active Member


Monday, May 21st 2007, 3:05pm

make sure both ports in the solenoid chamber are clear of debris, strip the paper off of a twist tie and slide it through both the holes to make sure they are clear.

Rate this thread