You are not logged in.




Sunday, August 13th 2017, 12:38pm

Hunter X-Core display not responding

I have an outdoor Hunter X-Core that's worked fine for 4 years. Today I went out to adjust the watering levels and got three dashes on the display when I turned the dial from Run. No big deal, I reset the controller but now neither the dial or buttons seem to do anything. After resetting, the display showed the blinking 12:00 AM but I am unable to even program the time. Turning the dial to Current Time/Day and pressing the plus/minus buttons have no effect. Likewise, turning the dial to System Off or Manual don't seem to do anything. The display isn't frozen exactly - it still keeps time (after 10 minutes the display will show 12:10, for instance) it just won't respond to any controls.

I hope that made sense. I have reset the controller several times to the same result. Thanks!



Posts: 2,272

Location: USA


Sunday, August 13th 2017, 3:27pm

It sounds like the controller's fried but,

Did you reset the controller via the instructions on page 26 of the manual?

Are there any sensors hooked up to the controller? If so, Try disconnecting that sensor then resetting.

I'm not hopeful that'll help you but it's all I have. It might be time for a new controller.

Rate this thread