You are not logged in.




Wednesday, July 26th 2017, 2:13pm

KwikDial Dial not working correctly

My 5 year old Irritrol KwikDial KD4 controller has a strange issue. The dial works fine as I turn it to the right - set time, set prog for each day etc. all the way to the 3rd station (stations 3 & 4 are not connected). Then, it shows the same screen as the Auto, then the next step is set time... etc.

As a result, I cannot turn the system off (1 stop to the left of Auto) or test or any of the functions which involve turning the dial to the left of Auto.

Here's a pic showing what is displayed when the dial is set to Off.

I have tried powering the controller off and on, tried resetting the board using the screwdriver to short the reset points. The programming that is currently set works just fine. The only thing that doesn't work is the dial.

What's going on? Anything I can do to fix this?
Thank you.



Posts: 2,009

Location: USA


Wednesday, July 26th 2017, 8:30pm

If rebooting the controller didn't fix the problem then it's going bad. Can you tap on the controller to make the display change?
Are you saying you pressed the reset button a the bottom right?




Thursday, July 27th 2017, 1:57pm

Yes, I did.

Funny you should ask about tapping the board. In my frustration, I hit the whole thing with my hand and it worked for a while :) I guess I should be looking to replace it.

Thank you.

Rate this thread