You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

dhami

Starting Member

1

Friday, September 23rd 2016, 4:29pm

Hunter X-core sc-800i dialer on controller malfunctioning

My x-core controller is approximately 4 years old and seems to now have a problem with the dial. When I try to turn the dial backward or forwards it seems that it is stuck and I have to apply force to turn it to a selected option. Moreover, the option I select isn't the one listed on the display. For example, when I have the dialer set at manual station and I chose the station I want to manually run using the keypad, I turn the dial to "Run" but what I have on the display is 2016 flashing (seems like this is the current time/day option). The dialer is somehow not correlating with the option selected. The sprinkler system still runs fine. Any suggestions to repair the dialer on controller or am I going to have to bite the bullet and get the entire controller replaced?

SunCoLawns

Advanced Member

Posts: 111

Location: Omaha, Nebraska, USA

2

Saturday, September 24th 2016, 8:45am

Sounds like it is time for a replacement. The dial is always the first thing to go.

Rate this thread