You are not logged in.

richu

New Member

1

Saturday, May 17th 2014, 12:54pm

Febco 765 vacuum problems

The Febco 765 vacuum on my sprinkler system has problems.
I saw it was leaking water. I bought a new Bonnet and Popit kit and installed them. I gently turned on the ball valve to the vacuum breaker. Water rushed up and leaked around the cap.
Does anyone have any ideas to help?

Wet_Boots

Supreme Member

Posts: 5,277

Location: Metro NYC

2

Saturday, May 17th 2014, 2:11pm

Close the ball valve on the outlet side of the device. Then open the water supply completely. There will always be a temporary rush of water from under the canopy, until the supply pressure seals it.

richu

New Member

3

Sunday, May 18th 2014, 10:51am

Febco 765 vacuum problems

I had the ball valve closed complete. Maybe I opened it too fast and too much pressure caused the problem. Could this be the problem?

Wet_Boots

Supreme Member

Posts: 5,277

Location: Metro NYC

4

Monday, May 19th 2014, 9:01am

Nothing you have posted is an indication of anything being faulty or broken. That water will escape from under the canopy when the supply valve is opened is an absolute. It WILL happen. If you only open the supply valve a fraction, the water will never stop flowing from under the canopy. That is also an absolute, and not an indication of anything being faulty.

Some water supplies are on the smaller side, and those always benefit from the outlet valve of the PVB being shut completely off, before opening the supply valve to the system, and even then there will be water escaping from under the canopy, on the way to the inner poppet sealing shut tight.

Similar threads

Rate this thread