You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

dizzle

Unregistered

1

Wednesday, July 25th 2012, 6:11pm

Irritrol 2700 Valve/Solenoid Issue?

Hey there,
Just moved into a new house that has an existing sprinkler system. After researching, it looks like I have the Irritrol 2700 system. Most of my zones work great, but I have 3 that just won't work with the controller and even when manually trying to run. When I turn the valve on manually on these valves, I can hear water running, but nothing happens. When I remove the solenoid and close the flow control knob the sprinkler heads work. I tried to put a known working solenoid on it but it didn't work. Any ideas? Thanks!!!

mrfixit

Moderator

Posts: 1,450

Location: USA

2

Wednesday, July 25th 2012, 9:13pm

If you closed the flow control all the way the sprinklers wont work. Maybe you're screwing them the wrong direction. Opening them when you think you're closing them.
Clockwise is closing, counter is opening.
---
Are you sure you have the 2700 series and not the old 711APR? Scroll down.
---
It could be the diaphragms are bad. For a sure fix you could buy three new valves and harvest the parts off of them.

Wet_Boots

Supreme Member

Posts: 4,030

Location: Metro NYC

3

Thursday, July 26th 2012, 6:45am

Bring back a photo of the old valves

Similar threads

Rate this thread