You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

rlwremo

Starting Member

1

Friday, August 3rd 2007, 1:57am

troubleshoot Richdel 500 pri irrigation controller

Hi,

I'm hoping someone can offer a suggestion for me. I have a Richdel 500 pri irrigation controller which is malfunctioning. It has power. I can set the time and program controller, but it is not 'triggering' any of the zones. Also, when I set any given zone to 'manual' the controller does not go into manual mode (normally when flipping a zone to manual the display changes and indicates that the zone is on). I've turned the unit off and reset it a couple of times with no effect.

Any thoughts, suggestions would be appreciated!!!

Thanks in advance.
Richard.

Wet_Boots

Supreme Member

Posts: 3,871

Location: Metro NYC

2

Friday, August 3rd 2007, 2:42am

Check your wiring for electrical continuity. Check the controller for output voltage/current.

mrfixit

Moderator

Posts: 1,416

Location: USA

3

Friday, August 3rd 2007, 6:36am

Sounds like the controller died on you. Try this. Disconnect the ground wire from the controller. Reset the controller. Now turn one on manually and see if it's working in the display. If not your controller's bad. Good luck!
If I can't fix it, it's broken!

SprinklerGuy

Supreme Member

4

Saturday, August 4th 2007, 3:10am

Could have gotten a spike...

Disconnect power to the timer....AND....remove the 9v battery...let it sit for a minute or two..then connect power again and try it......

Sprinkler Solutions, Inc.
Arizona and Colorado
www.sprinklersolutions.net

Rate this thread