You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

cosimiro

New Member

1

Monday, July 2nd 2012, 5:14am

Need Help - Irritrol KD6

Hi everybody,

I'm Cosimo, I'm writing from Italy.
I need help for my controller, Irritrol KD6.
I have a garden with 6 different zones, and I used the KD6 to set the time of start for irrigation and the time of single irrigation zone. But now I have a problem: the controller doesn't work.
If I put the handle of the KD6 in thne zone 1 and 2, I can set the time of irrigation. But if I put the handle on zone 3,4,5 and 6, the display will give me the time and the day of the week "SUN", "MON", "THU"... and I cannot set the irrigation time of that zones.
What do you think can be the cause of this problem? I tried to reset the controller, but nothing has changed. Can be a problem of fuse?
Thanks for your help.

Wet_Boots

Supreme Member

Posts: 4,020

Location: Metro NYC

2

Monday, July 2nd 2012, 7:21am

the international model of that controller has numbers for the days of the week, and setting the dial to one of the days-of-the-week numbers would not do anything regarding a particular zone

cosimiro

New Member

3

Monday, July 2nd 2012, 12:10pm

Thanks for your answer.

There is a wheel on this controller, and the situation it is like this:



So, if I put the dial on the numbers beetween 1 and 7 on the right side of the wheel, in the display appears the day of the week.
If I put the dial on the numbers beetween 1 and 6 on the left side of the wheel, in the display appear only the first two zones. When I put the wheel on the "3" in the display appears the time/set, in the "4" appears "MON"... like the figure.

What do you think can be the problem? I can't use this controller with this problem...

mrfixit

Moderator

Posts: 1,446

Location: USA

4

Monday, July 2nd 2012, 12:18pm

I thought maybe the handle was on upside down but even that doesn't make sense.
Time for a new controller.

cosimiro

New Member

5

Monday, July 2nd 2012, 12:27pm

Damn! :(
I bought this controller only 2 years ago... I cannot believe it is break. I tried to reset the unit but the problem remains the same. I hope it can be a problem of fuses... :(

Wet_Boots

Supreme Member

Posts: 4,020

Location: Metro NYC

6

Tuesday, July 3rd 2012, 8:07am

welcome to the world of modern consumer electronics - it takes only one tiny failure of the computer logic to kill the operation

what you describe could be explained by one part of a binary number code failing to switch from 0 to 1, or vice versa

maybe the controller is still under warranty

cosimiro

New Member

7

Tuesday, July 3rd 2012, 10:49am

Thanks for your answers, guys. And sorry if my english was bad :(

I'll try to talk with the shop wich sold the controller to me, I hope it can be repaired or changed.

Wet_Boots

Supreme Member

Posts: 4,020

Location: Metro NYC

8

Tuesday, July 3rd 2012, 11:43am

Thank you for the detailed photo, which reinforces the idea of a logic failure, because you can count sixteen steps from the 'run' position to the first position showing an error, and the other errors are sixteen steps away from the 'correct' switch position.

Rate this thread