You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Starting Member


Saturday, June 25th 2011, 11:51pm

Zone Won't Turn On

I'm a (somewhat) new homeowner and I'm trying to get my sprinkler system to work correctly. I have no idea what these people were doing, but they did not do this the easiest or most efficient way, that's for sure!

I finally got to where the drip line hooked up to the PVC pipe. I tested all my zones, 1 and 2 work ok, but 3 (the drip line) doesn't. When I turn it on, at the water it appears that it's turned on (there is a slight leak) but no water comes out the pipe/drip hose. I don't know what these parts are called, all I've ever worked with was the drip hose, sprinkler heads, etc.. never had to work on the other end.

Any suggestions of what I need to look at/try would be greatly appreciated. I am considering taking pictures of what I'm talking about and hitting up Lowes and hoping they can help but I thought I'd try to get some info here first.



Active Member

Posts: 25

Location: portland or.


Monday, July 4th 2011, 9:16pm

drip line zone

What you should find at the begining of the drip line is the valve, pressure regulater and filter. It sounds like one of two possible causes, eather the flow control ov the valve is closed or the filter is plugged. You should be able to unscrew the filter cap and flush the filter and see if that helps.

Rate this thread