You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

brotherbryce

Starting Member

1

Tuesday, July 25th 2006, 6:42am

valve not stopping water

I have to begin by saying I'm new to this sprinkler repair stuff. I just replaced my timer, then noticed some leaks in the system. I dug them up and they are some old orbit drain valves. They're draining water constantly. So I replace both drain valves and one still "leaks". So I replaced the control valve to the line, which had just started leaking also. That did not fix the problem. Any ideas?

xpedient

Active Member

Posts: 43

Location: USA

2

Friday, August 18th 2006, 3:52pm

Put a plug in there...
Xpedient Irrigation Inc. is a locally owned company that delivers solutions to all your sprinker system needs.
We service both residential and light commercial customers.

We offer: Complete installations
All types of Repairs
Summer start-ups
Evaluation of coverage
Troubleshooting
Pressure loss
Vacuum breaker repair
Drip/Low-Pressure Irrigation Installation and Repair
and Much More!

If you would like free consultation or advice for your property, please feel free to contact us with any questions!

Call or email us now to schedule your summer-start up!


http://www.highlandsranch.com/class/display.html?id=3537

Wet_Boots

Supreme Member

Posts: 4,029

Location: Metro NYC

3

Saturday, August 19th 2006, 4:16am

Try to find some 'King' drain fittings, they don't get clogged up.

Rate this thread