You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

2theweb4now

Starting Member

1

Saturday, April 16th 2011, 5:40pm

Richdel valve (possibly a 205) - All zones turn on at the same time

Hi,

I am new to all this so most likely I have no clue what I am talking about. :)

I have a sprinkler systems with three zones that has worked OK since I moved into this house. The zones were turning on one at a time and shutting off correctly. I have a timer mechanism with a big round orange disk and an a switch with three positions:
Auto
Off
Manual
The problem is that in both manual and auto all three zones turn on at the same time. From the research I've done it seems that the valve is a Richdel 205 (looks like an Irritrol 205). Any idea what is wrong with this thing?

Any help is much appreciated!

Thank you!

Mitchgo

Supreme Member

Posts: 502

Location: Seattle

2

Saturday, April 16th 2011, 7:01pm

Sounds like a imperial valet controller- old school

Could be a number of issues.. A step by step electrical diagnosis really should be done to properly identify.

3 bigger things that come to mind is the system has a master valve and the 3 zones are manually turned on/ stuck on. Or The controller is wired incorrectly or the controller has gone bad and now is sending power to all 3 zones

Wet_Boots

Supreme Member

Posts: 3,884

Location: Metro NYC

3

Sunday, April 17th 2011, 9:54am

Make sure the valves aren't still manually opened from last year's winterizing.

-

Take photos of the controller, and post them, so we know what you have.

lforstuff

Unregistered

4

Tuesday, April 19th 2011, 12:45pm

Richdel valve (possibly a 205) - All zones turn on at the same time

Hi,

I am new to all this so most likely I have no clue what I am talking about. :)

I have a sprinkler systems with three zones that has worked OK since I moved into this house. The zones were turning on one at a time and shutting off correctly. I have a timer mechanism with a big round orange disk and an a switch with three positions:
Auto
Off
Manual
The problem is that in both manual and auto all three zones turn on at the same time. From the research I've done it seems that the valve is a Richdel 205 (looks like an Irritrol 205). Any idea what is wrong with this thing?

Any help is much appreciated!

Thank you!

lforstuff

Unregistered

5

Tuesday, April 19th 2011, 12:48pm

I will try to take a picture and post it once my internet comes back up. Someone cut the phone cable in the neighborhood. :)
I took a closer look at that thing and I noticed that after the water goes thru the valve it enters something pretty big, round and green (told you I am am clueless :)). I noticed 4 screws holding a cap in place on top of it so i decided to take the cap of. After taking it off I noticed a shaft that could be turned by hand. I turned it by hand and messed with it for a few minutes realizing that most likely that is the thing that by turning around opens and closes the zones. After putting the cap back on the wrong way on the first try, I managed the second time around to put it back on the right way. :) Then I turned the the sprinkler on to manual and just one zone came on. Then I turned it off then back on and a different zone came on. Turned it of again and back again and the third zone came on. So it looks like it is working OK for now. It must have gotten stuck.

Thank you for taking you time and helping out.

Wet_Boots

Supreme Member

Posts: 3,884

Location: Metro NYC

6

Wednesday, April 20th 2011, 12:11pm

You have an indexing valve. It got stuck. You unstuck it.

Similar threads

Rate this thread