You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Mitchell

New Member

1

Sunday, February 27th 2011, 1:29pm

Nelson Valves

?( I turned my water pump and control box on yesterday. 3 of the 4 valves are leaking whether the timer is on or not. The only one that is not leaking will not come on at all. Any suggestions from anyone?

hi.todd

Supreme Member

Posts: 415

Location: Houston, Texas

2

Sunday, February 27th 2011, 4:10pm

Find the valves in the field and then open them up manually by the solenoid and then close the solenoid try to see if the solenoid was loose. Tighten it! Then if there is a manual bleed screw open it. Then close it fairly tight.

Good Luck

:thumbsup: :thumbsup: :thumbsup: :thumbsup:
:thumbup: :thumbsup:

Mitchell

New Member

3

Sunday, February 27th 2011, 6:38pm

VALVES

Thanks, Hi.Todd. The valve that would not come on is bad. Checked it with a meter. Current coming to the valve when the valve should be activated but valve not working.



I checked the valves that were leaking. Apparently, there is some trash in them. I can activate the zone with the solenoid by turning it and cut it off by tightening it but all 3 are still leaking.

Mitchell

New Member

4

Monday, February 28th 2011, 7:25pm

nelson valves

I took the 3 valves apart, cleaned them blew them out with an air hose, put them back together. STILL LEAKING!



Any ideas as to what to do next?

Rate this thread