You are not logged in.

Not Sure What's Wrong?

If you are not sure what is wrong with your sprinkler system, this section is set aside for giving advice on general troubleshooting and diagnostic techniques. There are tools and techniques that are vital!

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Texas*Golf*Bum (Jan 8th 2015, 5:03pm)

1 324

by irrigirl

(Jan 9th 2015, 8:42am)

by t1021ru (Sep 8th 2009, 9:43am)

8 1,105

by Wet_Boots

(May 29th 2010, 9:35am)

by NewtoAZ (Dec 9th 2011, 2:16pm)

4 329

by new to az

(Jan 11th 2012, 2:39pm)

by wakeboarder141 (Jul 6th 2010, 12:26pm)

1 958

by Wet_Boots

(Jul 6th 2010, 1:08pm)

by markgouin (Aug 6th 2011, 3:54pm)

5 2,060

by mrfixit

(Sep 20th 2011, 5:34pm)

by rmbuchalski (Jul 1st 2011, 3:46pm)

1 308

by Mitchgo

(Jul 1st 2011, 9:26pm)

by rubeshooz (Apr 4th 2007, 11:17am)

2 516

by lush96

(May 14th 2007, 8:59pm)

by notveryhandy828 (Jul 9th 2011, 9:18pm)

4 474

by Mitchgo

(Jul 11th 2011, 12:42am)

by Packrat (Apr 18th 2004, 1:47pm)

0 241

No reply

by smogcops (Aug 3rd 2006, 1:06pm)

3 298

by Bill Painter

(Aug 10th 2006, 4:58am)

Show

Statistics:

820 Threads - 3,489 Posts (average 0.72 Posts per Day)