You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by John199 (Aug 14th 2011, 3:57pm)

4 733

by hi.todd

(Aug 15th 2011, 7:29pm)

by Mac54321 (Jul 13th 2011, 10:03am)

1 732

by Wet_Boots

(Jul 13th 2011, 11:30am)

by harrisst14 (Jun 10th 2012, 6:29pm)

1 726

by mrfixit

(Jun 10th 2012, 8:13pm)

by stillc (Jul 29th 2009, 12:36pm)

2 717

by Wet_Boots

(Aug 4th 2009, 1:08am)

by bluetractormanc (Aug 9th 2011, 10:59pm)

1 699

by Wet_Boots

(Aug 10th 2011, 7:51am)

by lonnieclar (Jul 22nd 2008, 7:06pm)

1 696

by mrfixit

(Jul 22nd 2008, 9:30pm)

by redlinr (Jun 9th 2005, 3:46am)

3 693

by Jazzer K

(Sep 2nd 2005, 6:14pm)

by ncampbel (Jul 1st 2011, 2:15pm)

1 692

by Mitchgo

(Jul 1st 2011, 9:20pm)

by patk (Sep 18th 2011, 2:17pm)

2 687

by patk

(Sep 18th 2011, 3:41pm)

by KSknight (Aug 17th 2009, 10:53am)

1 683

by bdbengtsson

(May 21st 2010, 5:27pm)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)