You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by cassian (Aug 16th 2005, 6:44am)

1 946

by RidgeRun05

(Aug 16th 2005, 1:28pm)

by guill34 (Jun 4th 2007, 6:49am)

2 940

by guill34

(Jun 4th 2007, 1:11pm)

by pohall@kivexmail.com (May 13th 2006, 9:21am)

1 933

by jmduke7

(Aug 17th 2006, 3:13pm)

by Eastern chubbytool (Aug 8th 2010, 2:49pm)

2 932

by hi.todd

(Aug 10th 2010, 11:57am)

by davew (Jul 4th 2005, 11:17am)

2 930

by davew

(Jul 5th 2005, 10:54am)

by Trabecca (Mar 13th 2013, 6:22pm)

7 923

by Trabecca

(Mar 18th 2013, 8:23am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 889

by ddeferra

(Jun 8th 2011, 6:29pm)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 886

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by mdige (Oct 31st 2011, 4:31pm)

1 867

by Wet_Boots

(Nov 1st 2011, 6:36am)

by pjansen19 (Nov 7th 2011, 4:18pm)

3 863

by mrfixit

(Nov 10th 2011, 4:23am)

Show

Statistics:

475 Threads - 1,785 Posts (average 0.36 Posts per Day)