You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by harrisst14 (Jun 10th 2012, 6:29pm)

1 826

by mrfixit

(Jun 10th 2012, 8:13pm)

by John199 (Aug 14th 2011, 3:57pm)

4 823

by hi.todd

(Aug 15th 2011, 7:29pm)

by Mac54321 (Jul 13th 2011, 10:03am)

1 798

by Wet_Boots

(Jul 13th 2011, 11:30am)

by Trabecca (Mar 13th 2013, 6:22pm)

7 796

by Trabecca

(Mar 18th 2013, 8:23am)

by stillc (Jul 29th 2009, 12:36pm)

2 787

by Wet_Boots

(Aug 4th 2009, 1:08am)

by mdige (Oct 31st 2011, 4:31pm)

1 782

by Wet_Boots

(Nov 1st 2011, 6:36am)

by Michael (May 1st 2006, 3:41pm)

4 770

by Michael

(May 2nd 2006, 3:25am)

by bluetractormanc (Aug 9th 2011, 10:59pm)

1 767

by Wet_Boots

(Aug 10th 2011, 7:51am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 757

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by guy_sparky (Aug 12th 2010, 10:35am)

3 757

by mrfixit

(Aug 12th 2010, 5:12pm)

Show

Statistics:

437 Threads - 1,667 Posts (average 0.35 Posts per Day)