You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Katy (Jun 1st 2012, 3:41pm)

2 187

by hi.todd

(Jun 1st 2012, 8:55pm)

by shrpshtr (Apr 26th 2011, 12:32am)

0 390

No reply

by Audit (Jun 14th 2006, 2:16am)

1 193

by xpedient

(Jun 25th 2006, 6:27pm)

by jchsmiller (Apr 18th 2011, 11:47am)

1 266

by Wet_Boots

(Apr 20th 2011, 12:27pm)

by tinkermaniac (Aug 21st 2002, 2:36pm)

1 225

by Rays Sprinklers

(May 17th 2003, 2:51pm)

by Kpierce (Apr 12th 2013, 10:36pm)

1 191

by Wet_Boots

(Apr 13th 2013, 10:46am)

by bbruck (Jun 20th 2009, 7:11pm)

1 328

by Wet_Boots

(Jun 21st 2009, 8:31am)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 316

by Mitchgo

(May 9th 2011, 1:04am)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 389

by Mitchgo

(Jul 19th 2011, 12:34am)

by orgits (Apr 9th 2011, 5:10pm)

2 553

by Mitchgo

(Apr 10th 2011, 2:29am)

Show

Statistics:

431 Threads - 1,630 Posts (average 0.36 Posts per Day)