You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 7907 (May 3rd 2013, 12:55am)

2 354

by PennyInHeels

(Jun 25th 2013, 9:49am)

by tico (Jun 15th 2013, 8:58pm)

0 463

No reply

by gobris (May 14th 2013, 9:45am)

3 540

by Wet_Boots

(May 16th 2013, 8:30am)

by Rmiclette (May 5th 2013, 6:49am)

2 376

by Scott76

(May 5th 2013, 11:41am)

by Caltino (Apr 12th 2013, 7:18pm)

12 1,175

by Wet_Boots

(Apr 27th 2013, 7:42am)

by Sartenose (Sep 22nd 2012, 2:31pm)

1 557

by Wet_Boots

(Sep 22nd 2012, 10:06pm)

by rsteffan (Aug 1st 2012, 6:14pm)

6 638

by Wet_Boots

(Aug 22nd 2012, 10:52am)

by joe13 (Aug 19th 2012, 12:36pm)

1 452

by Wet_Boots

(Aug 19th 2012, 2:35pm)

by lalloo (Aug 5th 2012, 11:02am)

2 271

by GatorGuy

(Aug 6th 2012, 9:13am)

by fmayerjr (Aug 2nd 2012, 10:47am)

1 335

by Wet_Boots

(Aug 2nd 2012, 2:16pm)

Show

Statistics:

460 Threads - 1,720 Posts (average 0.36 Posts per Day)