You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Rick Hudspeth (May 31st 2006, 5:13am)

2 484

by Rick Hudspeth

(May 31st 2006, 7:35am)

by sgb (Jun 5th 2006, 5:30pm)

0 378

No reply

by bzook@aol.com (Jun 8th 2006, 1:47pm)

1 176

by Wet_Boots

(Jun 8th 2006, 3:46pm)

by jhardwick (Jun 10th 2006, 1:26pm)

0 200

No reply

by SteveM099 (Jun 15th 2006, 2:09pm)

1 187

by SteveM099

(Jun 15th 2006, 2:21pm)

by tabong (Jun 18th 2006, 5:10pm)

1 152

by Wet_Boots

(Jun 19th 2006, 5:44am)

by SteveM099 (Jun 19th 2006, 1:50am)

1 188

by Wet_Boots

(Jun 19th 2006, 6:17am)

by Audit (Jun 14th 2006, 2:16am)

1 205

by xpedient

(Jun 25th 2006, 6:27pm)

by rcajun36 (Jun 26th 2006, 5:13am)

3 1,227

by xpedient

(Jun 26th 2006, 6:53am)

by csnugg (Jun 26th 2006, 4:10pm)

0 516

No reply

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)