You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by richard1975 (Apr 28th 2013, 7:12pm)

1 324

by Scott76

(May 2nd 2013, 2:06pm)

by Caltino (Apr 12th 2013, 7:18pm)

12 1,317

by Wet_Boots

(Apr 27th 2013, 7:42am)

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 372

by mrfixit

(Apr 17th 2013, 5:56pm)

by Kpierce (Apr 12th 2013, 10:36pm)

1 328

by Wet_Boots

(Apr 13th 2013, 10:46am)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 426

by Ianjanson

(Apr 10th 2013, 7:37pm)

by Binks (Apr 10th 2013, 1:28am)

1 313

by mrfixit

(Apr 10th 2013, 3:02am)

by Trabecca (Mar 13th 2013, 6:22pm)

7 892

by Trabecca

(Mar 18th 2013, 8:23am)

by Island Sprinklers (Mar 12th 2013, 10:47am)

1 603

by Wet_Boots

(Mar 12th 2013, 11:42am)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 448

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by Marvel (Jan 19th 2013, 6:54am)

7 1,314

by Marvel

(Jan 22nd 2013, 7:49pm)

Show

Statistics:

465 Threads - 1,754 Posts (average 0.36 Posts per Day)