You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 259

by mrfixit

(Oct 16th 2011, 2:26am)

by keitht (Apr 11th 2006, 3:53pm)

1 259

by BSME

(Apr 12th 2006, 5:45am)

by ahersman (Sep 30th 2009, 1:37pm)

1 260

by ahersman

(Sep 30th 2009, 6:15pm)

by gerald (May 31st 2006, 5:44am)

2 260

by jmduke7

(Aug 17th 2006, 3:03pm)

by Hammy69 (Jun 16th 2009, 9:46am)

1 261

by hi.todd

(Jun 19th 2009, 10:29pm)

by andyl (Apr 21st 2014, 8:32pm)

3 262

by Wet_Boots

(Apr 27th 2014, 9:26am)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 263

by jmduke7

(Aug 16th 2006, 6:36pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 263

by Wet_Boots

(Jun 19th 2006, 6:17am)

by frankmanic (Aug 5th 2010, 8:44am)

0 265

No reply

by runningfreak (May 25th 2011, 7:32pm)

1 266

by Wet_Boots

(May 25th 2011, 8:29pm)

Show

Statistics:

472 Threads - 1,758 Posts (average 0.36 Posts per Day)