You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by shellbeach (Sep 27th 2010, 4:18pm)

2 177

by Wet_Boots

(Sep 28th 2010, 1:11pm)

by Tee Jay (May 17th 2007, 8:38am)

3 177

by Bill Painter

(May 21st 2007, 1:12pm)

by Hammy69 (Jun 16th 2009, 9:46am)

1 178

by hi.todd

(Jun 19th 2009, 10:29pm)

by Bonelawr (Jul 29th 2012, 9:45am)

2 180

by Bonelawr

(Jul 29th 2012, 11:38am)

by abhnoclue (Jun 16th 2007, 10:57am)

2 180

by abhnoclue

(Jun 17th 2007, 6:20am)

by maddog (Sep 8th 2011, 5:48pm)

1 181

by grey

(Sep 9th 2011, 11:40am)

by SteveM099 (Jun 15th 2006, 2:09pm)

1 181

by SteveM099

(Jun 15th 2006, 2:21pm)

by richard1975 (Apr 28th 2013, 7:12pm)

1 182

by Scott76

(May 2nd 2013, 2:06pm)

by RodQ (Jul 11th 2010, 12:54pm)

2 182

by hi.todd

(Jul 12th 2010, 12:49pm)

by Binks (Apr 10th 2013, 1:28am)

1 184

by mrfixit

(Apr 10th 2013, 3:02am)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)