You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by runningfreak (May 25th 2011, 7:32pm)

1 216

by Wet_Boots

(May 25th 2011, 8:29pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 216

by Wet_Boots

(Jun 19th 2006, 6:17am)

by SteveM099 (Jun 15th 2006, 2:09pm)

1 216

by SteveM099

(Jun 15th 2006, 2:21pm)

by jhardwick (Jun 10th 2006, 1:26pm)

0 216

No reply

by sbradfor (Jul 20th 2003, 7:40am)

1 216

by Rays Sprinklers

(Jul 20th 2003, 7:49am)

by Hammy69 (Jun 16th 2009, 9:46am)

1 217

by hi.todd

(Jun 19th 2009, 10:29pm)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 219

by jmduke7

(Aug 16th 2006, 6:36pm)

by alf51175 (Aug 1st 2011, 9:53pm)

3 221

by alf51175

(Aug 2nd 2011, 8:02pm)

by RodQ (Jul 11th 2010, 12:54pm)

2 221

by hi.todd

(Jul 12th 2010, 12:49pm)

by billt (Aug 28th 2010, 10:20am)

1 222

by Wet_Boots

(Aug 28th 2010, 11:21am)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)