You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Hammy69 (Jun 16th 2009, 9:46am)

1 198

by hi.todd

(Jun 19th 2009, 10:29pm)

by abhnoclue (Jun 16th 2007, 10:57am)

2 199

by abhnoclue

(Jun 17th 2007, 6:20am)

by SteveM099 (Jun 19th 2006, 1:50am)

1 199

by Wet_Boots

(Jun 19th 2006, 6:17am)

by shellbeach (Sep 27th 2010, 4:18pm)

2 201

by Wet_Boots

(Sep 28th 2010, 1:11pm)

by Oscar S. Ramirez (Mar 21st 2014, 5:28pm)

1 202

by mrfixit

(Mar 22nd 2014, 1:58am)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 202

by jmduke7

(Aug 16th 2006, 6:36pm)

by SteveM099 (Jun 15th 2006, 2:09pm)

1 202

by SteveM099

(Jun 15th 2006, 2:21pm)

by sbradfor (Jul 20th 2003, 7:40am)

1 202

by Rays Sprinklers

(Jul 20th 2003, 7:49am)

by billt (Aug 28th 2010, 10:20am)

1 203

by Wet_Boots

(Aug 28th 2010, 11:21am)

by keitht (Apr 11th 2006, 3:53pm)

1 203

by BSME

(Apr 12th 2006, 5:45am)

Show

Statistics:

436 Threads - 1,654 Posts (average 0.36 Posts per Day)