You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by lybrand (Aug 30th 2012, 3:54pm)

1 389

by Wet_Boots

(Aug 30th 2012, 4:50pm)

by mugentuner (Aug 30th 2004, 12:30pm)

1 126

by mugentuner

(Sep 6th 2004, 8:44am)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 119

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by tc1458 (Apr 13th 2005, 9:37am)

5 391

by Jazzer K

(Sep 2nd 2005, 6:17pm)

by SpritzCan (Apr 21st 2012, 8:33pm)

2 119

by GatorGuy

(Apr 23rd 2012, 8:47am)

by Dennis (Oct 15th 2007, 7:30am)

1 477

by edwildesr

(Nov 5th 2007, 7:53am)

by peetey37 (May 22nd 2006, 7:17am)

1 243

by nestors

(May 27th 2006, 5:31pm)

by Jonas_ (Mar 14th 2012, 6:16am)

1 289

by GatorGuy

(Mar 14th 2012, 7:35am)

by jbbnet (Aug 19th 2004, 5:11pm)

3 102

by SamIV

(Aug 29th 2004, 5:43am)

by svsprinklers (May 19th 2010, 9:29pm)

2 952

by PhoenixDen

(Jun 24th 2010, 11:27am)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)