You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 498

by Wet_Boots

(Dec 26th 2012, 8:32am)

by ddak32@yahoo.com (Oct 17th 2012, 3:09pm)

1 585

by Wet_Boots

(Oct 17th 2012, 5:31pm)

by ragtop69 (Oct 12th 2012, 7:11pm)

1 936

by Wet_Boots

(Oct 12th 2012, 10:24pm)

by Sartenose (Sep 22nd 2012, 2:31pm)

1 565

by Wet_Boots

(Sep 22nd 2012, 10:06pm)

by lybrand (Aug 30th 2012, 3:54pm)

1 600

by Wet_Boots

(Aug 30th 2012, 4:50pm)

by grey (Aug 24th 2012, 6:29pm)

1 513

by grey

(Aug 25th 2012, 2:19pm)

by joe13 (Aug 19th 2012, 12:36pm)

1 468

by Wet_Boots

(Aug 19th 2012, 2:35pm)

by fmayerjr (Aug 2nd 2012, 10:47am)

1 346

by Wet_Boots

(Aug 2nd 2012, 2:16pm)

by MEL88 (Jul 19th 2012, 12:20pm)

1 251

by GatorGuy

(Jul 19th 2012, 2:14pm)

by AWCiesiel (Jul 13th 2012, 8:42pm)

1 494

by mrfixit

(Jul 14th 2012, 12:39am)

Show

Statistics:

472 Threads - 1,758 Posts (average 0.36 Posts per Day)