You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by nowaterflow (Mar 8th 2013, 3:52pm)

3 472

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by Terri (Jan 9th 2013, 6:46am)

1 431

by Wet_Boots

(Jan 9th 2013, 11:08am)

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 526

by Wet_Boots

(Dec 26th 2012, 8:32am)

by rockypoint (Nov 26th 2012, 6:02pm)

2 705

by mrfixit

(Nov 26th 2012, 7:30pm)

by Jlivengood (Oct 20th 2012, 2:01am)

3 723

by Wet_Boots

(Oct 20th 2012, 5:11pm)

by ddak32@yahoo.com (Oct 17th 2012, 3:09pm)

1 655

by Wet_Boots

(Oct 17th 2012, 5:31pm)

by diegogarcia67 (Sep 22nd 2012, 6:32pm)

0 354

No reply

by rose (Sep 11th 2012, 12:24pm)

0 280

No reply

by desmo907 (Aug 28th 2012, 3:54pm)

3 569

by desmo907

(Sep 4th 2012, 8:33am)

by garen (Aug 8th 2012, 10:41pm)

7 771

by Wet_Boots

(Aug 24th 2012, 8:00am)

Show

Statistics:

476 Threads - 1,794 Posts (average 0.36 Posts per Day)