You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Island Sprinklers (Mar 12th 2013, 10:47am)

1 570

by Wet_Boots

(Mar 12th 2013, 11:42am)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 414

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by Marvel (Jan 19th 2013, 6:54am)

7 1,252

by Marvel

(Jan 22nd 2013, 7:49pm)

by Terri (Jan 9th 2013, 6:46am)

1 405

by Wet_Boots

(Jan 9th 2013, 11:08am)

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 496

by Wet_Boots

(Dec 26th 2012, 8:32am)

by rockypoint (Nov 26th 2012, 6:02pm)

2 660

by mrfixit

(Nov 26th 2012, 7:30pm)

by dgaines (Nov 5th 2012, 5:27pm)

3 934

by dgaines

(Nov 10th 2012, 4:15pm)

by GregM (Mar 17th 2011, 9:20am)

23 4,096

by mrfixit

(Nov 1st 2012, 9:39pm)

by Jlivengood (Oct 20th 2012, 2:01am)

3 668

by Wet_Boots

(Oct 20th 2012, 5:11pm)

by njchoochoo1 (Oct 16th 2012, 8:13pm)

3 643

by Wet_Boots

(Oct 18th 2012, 9:14am)

Show

Statistics:

471 Threads - 1,753 Posts (average 0.36 Posts per Day)