You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by rsteffan (Aug 1st 2012, 6:14pm)

6 463

by Wet_Boots

(Aug 22nd 2012, 10:52am)

by joe13 (Aug 19th 2012, 12:36pm)

1 304

by Wet_Boots

(Aug 19th 2012, 2:35pm)

by lalloo (Aug 5th 2012, 11:02am)

2 153

by GatorGuy

(Aug 6th 2012, 9:13am)

by fmayerjr (Aug 2nd 2012, 10:47am)

1 234

by Wet_Boots

(Aug 2nd 2012, 2:16pm)

by ksrmc (Aug 1st 2012, 3:27pm)

6 409

by Wet_Boots

(Aug 2nd 2012, 9:31am)

by Bonelawr (Jul 29th 2012, 9:45am)

2 163

by Bonelawr

(Jul 29th 2012, 11:38am)

by nrwe (Jul 19th 2012, 1:57pm)

4 461

by mrfixit

(Jul 20th 2012, 3:06pm)

by sirlar (Jul 20th 2012, 2:40pm)

0 170

No reply

by MEL88 (Jul 19th 2012, 12:20pm)

1 164

by GatorGuy

(Jul 19th 2012, 2:14pm)

by AWCiesiel (Jul 13th 2012, 8:42pm)

1 346

by mrfixit

(Jul 14th 2012, 12:39am)

Show

Statistics:

430 Threads - 1,626 Posts (average 0.36 Posts per Day)