You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ahersman (Sep 30th 2009, 1:37pm)

1 250

by ahersman

(Sep 30th 2009, 6:15pm)

by Hammy69 (Jun 16th 2009, 9:46am)

1 250

by hi.todd

(Jun 19th 2009, 10:29pm)

by SteveM099 (Jun 19th 2006, 1:50am)

1 251

by Wet_Boots

(Jun 19th 2006, 6:17am)

by rickesco (Jul 28th 2004, 8:13am)

3 251

by aquamatic

(Jul 29th 2004, 10:36am)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 252

by jmduke7

(Aug 16th 2006, 6:36pm)

by gerald (May 31st 2006, 5:44am)

2 253

by jmduke7

(Aug 17th 2006, 3:03pm)

by runningfreak (May 25th 2011, 7:32pm)

1 256

by Wet_Boots

(May 25th 2011, 8:29pm)

by frankmanic (Aug 5th 2010, 8:44am)

0 257

No reply

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 259

No reply

by clm716 (Aug 7th 2011, 9:58am)

1 259

by Central Irrigation

(Aug 7th 2011, 10:49am)

Show

Statistics:

438 Threads - 1,679 Posts (average 0.35 Posts per Day)