You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 0303maz (Jun 12th 2012, 9:20am)

1 211

by mrfixit

(Jun 12th 2012, 9:45am)

by rickesco (Jul 28th 2004, 8:13am)

3 211

by aquamatic

(Jul 29th 2004, 10:36am)

by lalloo (Aug 5th 2012, 11:02am)

2 212

by GatorGuy

(Aug 6th 2012, 9:13am)

by bzook@aol.com (Jun 8th 2006, 1:47pm)

1 215

by Wet_Boots

(Jun 8th 2006, 3:46pm)

by killerj (May 25th 2009, 10:32am)

0 216

No reply

by jhardwick (Jun 10th 2006, 1:26pm)

0 217

No reply

by maddog (Sep 8th 2011, 5:48pm)

1 218

by grey

(Sep 9th 2011, 11:40am)

by janeandjoseph (Jul 6th 2004, 11:05pm)

2 218

by janeandjoseph

(Jul 7th 2004, 8:03pm)

by SteveM099 (Jun 15th 2006, 2:09pm)

1 219

by SteveM099

(Jun 15th 2006, 2:21pm)

by sbradfor (Jul 20th 2003, 7:40am)

1 219

by Rays Sprinklers

(Jul 20th 2003, 7:49am)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)