You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 198

by mrfixit

(Oct 16th 2011, 2:26am)

by AWCiesiel (Jul 13th 2012, 8:42pm)

1 432

by mrfixit

(Jul 14th 2012, 12:39am)

by jhardwick (Jun 10th 2006, 1:26pm)

0 222

No reply

by Eastern chubbytool (Aug 8th 2010, 2:49pm)

2 817

by hi.todd

(Aug 10th 2010, 11:57am)

by 68watford (Apr 30th 2006, 9:14am)

0 157

No reply

by alscarpati (May 20th 2006, 2:02am)

5 529

by alscarpati

(May 21st 2006, 7:02am)

by Binks (Apr 10th 2013, 1:28am)

1 241

by mrfixit

(Apr 10th 2013, 3:02am)

by sgb (Jun 5th 2006, 5:30pm)

0 419

No reply

by quick11 (Oct 7th 2010, 10:53am)

3 455

by Wet_Boots

(Oct 23rd 2010, 9:10am)

by Brun (Apr 29th 2008, 6:59am)

4 1,916

by hi.todd

(Nov 16th 2011, 4:49pm)

Show

Statistics:

455 Threads - 1,700 Posts (average 0.36 Posts per Day)