You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Drski (Jul 29th 2011, 11:50am)

5 818

by Drski

(Aug 9th 2011, 11:04am)

by Smithwilde (Aug 1st 2011, 1:23pm)

5 427

by Smithwilde

(Aug 1st 2011, 8:37pm)

by bherholz (May 16th 2011, 12:06pm)

5 1,460

by mrfixit

(Jun 7th 2011, 5:46pm)

by wrx884 (Apr 22nd 2011, 12:57am)

5 1,767

by Wet_Boots

(Apr 25th 2011, 9:37am)

by shakeum (Sep 19th 2010, 8:50pm)

5 880

by Wet_Boots

(Sep 25th 2010, 7:21am)

by t_shea (Sep 18th 2010, 10:46am)

5 3,161

by Wet_Boots

(Sep 20th 2010, 1:01pm)

by beanpole (Aug 21st 2010, 10:20pm)

5 1,207

by Wet_Boots

(Aug 24th 2010, 12:57pm)

by daniels (Aug 7th 2007, 11:14am)

5 4,051

by MrMark757

(Aug 9th 2010, 2:36am)

by Emblazed (Jul 24th 2010, 10:30am)

5 727

by Wet_Boots

(Jul 27th 2010, 10:48am)

by kingtpt (Jul 17th 2010, 5:57pm)

5 408

by Fireguy97

(Jul 18th 2010, 11:35pm)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)