You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Lonesomedave (Oct 16th 2015, 7:38am)

1 397

by Wet_Boots

(Oct 16th 2015, 10:46am)

by 09KR0058 (Oct 13th 2015, 6:11pm)

1 211

by 09KR0058

(Oct 13th 2015, 6:42pm)

by MichaelABQ (Sep 15th 2015, 1:11am)

1 208

by mrfixit

(Sep 15th 2015, 4:19am)

by Artie (Sep 2nd 2015, 7:27am)

1 419

by Wet_Boots

(Sep 2nd 2015, 8:10am)

by fbg (Aug 13th 2015, 4:40pm)

1 493

by Central Irrigation

(Aug 13th 2015, 6:38pm)

by Jamie (Jul 29th 2015, 6:17pm)

1 186

by mrfixit

(Jul 29th 2015, 11:48pm)

by Sebastian2015 (Jul 28th 2015, 9:27am)

1 186

by Wet_Boots

(Jul 28th 2015, 11:15am)

by bjlarson (Jul 28th 2015, 9:20am)

1 97

by Wet_Boots

(Jul 28th 2015, 10:04am)

by OldBob (Jul 23rd 2015, 7:37am)

1 139

by OldBob

(Jul 23rd 2015, 8:13pm)

by Behan (Jul 17th 2015, 1:38pm)

1 146

by mrfixit

(Jul 17th 2015, 6:45pm)

Show

Statistics:

505 Threads - 1,935 Posts (average 0.37 Posts per Day)