You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by betsycam (Oct 13th 2013, 4:26pm)

1 734

by Wet_Boots

(Oct 14th 2013, 10:18am)

by birdwatcher (Sep 30th 2013, 1:59pm)

1 330

by mrfixit

(Sep 30th 2013, 5:32pm)

by mydogcleo (Aug 28th 2013, 10:11am)

1 374

by Wet_Boots

(Aug 28th 2013, 1:36pm)

by Freddyfrom fl (Aug 6th 2013, 6:49pm)

1 294

by Wet_Boots

(Aug 6th 2013, 9:29pm)

by pjmckellar (Jul 27th 2013, 8:25am)

1 333

by Central Irrigation

(Jul 27th 2013, 9:42am)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 333

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by rickthedrummer101 (May 11th 2013, 2:26pm)

1 353

by Wet_Boots

(May 11th 2013, 5:08pm)

by richard1975 (Apr 28th 2013, 7:12pm)

1 319

by Scott76

(May 2nd 2013, 2:06pm)

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 370

by mrfixit

(Apr 17th 2013, 5:56pm)

by Kpierce (Apr 12th 2013, 10:36pm)

1 325

by Wet_Boots

(Apr 13th 2013, 10:46am)

Show

Statistics:

458 Threads - 1,728 Posts (average 0.36 Posts per Day)