You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Freddyfrom fl (Aug 6th 2013, 6:49pm)

1 333

by Wet_Boots

(Aug 6th 2013, 9:29pm)

by pjmckellar (Jul 27th 2013, 8:25am)

1 380

by Central Irrigation

(Jul 27th 2013, 9:42am)

by cjohnson2020 (Jul 26th 2013, 4:31pm)

2 417

by mrfixit

(Jul 27th 2013, 2:59am)

by BessMan94 (Jun 24th 2013, 8:45pm)

3 555

by mrfixit

(Jun 25th 2013, 8:32pm)

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 668

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 391

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by ruchuck (May 29th 2013, 8:54am)

7 864

by mrfixit

(Jun 2nd 2013, 12:03am)

by rickthedrummer101 (May 11th 2013, 2:26pm)

1 401

by Wet_Boots

(May 11th 2013, 5:08pm)

by richard1975 (Apr 28th 2013, 7:12pm)

1 373

by Scott76

(May 2nd 2013, 2:06pm)

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 417

by mrfixit

(Apr 17th 2013, 5:56pm)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)