You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by gobris (May 14th 2013, 9:45am)

3 560

by Wet_Boots

(May 16th 2013, 8:30am)

by rickthedrummer101 (May 11th 2013, 2:26pm)

1 337

by Wet_Boots

(May 11th 2013, 5:08pm)

by Rmiclette (May 5th 2013, 6:49am)

2 387

by Scott76

(May 5th 2013, 11:41am)

by richard1975 (Apr 28th 2013, 7:12pm)

1 306

by Scott76

(May 2nd 2013, 2:06pm)

by Caltino (Apr 12th 2013, 7:18pm)

12 1,208

by Wet_Boots

(Apr 27th 2013, 7:42am)

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 351

by mrfixit

(Apr 17th 2013, 5:56pm)

by Kpierce (Apr 12th 2013, 10:36pm)

1 313

by Wet_Boots

(Apr 13th 2013, 10:46am)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 401

by Ianjanson

(Apr 10th 2013, 7:37pm)

by Binks (Apr 10th 2013, 1:28am)

1 296

by mrfixit

(Apr 10th 2013, 3:02am)

by Trabecca (Mar 13th 2013, 6:22pm)

7 829

by Trabecca

(Mar 18th 2013, 8:23am)

Show

Statistics:

471 Threads - 1,753 Posts (average 0.36 Posts per Day)