You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by WS-1 (May 9th 2010, 4:29pm)

28 11,508

by Romeo

(Jun 10th 2014, 3:57am)

by ash13 (Jun 1st 2014, 10:06am)

4 298

by Central Irrigation

(Jun 1st 2014, 6:17pm)

by LT87 (May 21st 2014, 11:33am)

3 228

by hi.todd

(May 27th 2014, 1:03pm)

by noquarter (May 24th 2014, 1:22pm)

6 281

by Wet_Boots

(May 26th 2014, 6:22am)

by abcoker (May 9th 2014, 2:43pm)

5 485

by Wet_Boots

(May 23rd 2014, 7:04am)

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 307

No reply

by andyl (Apr 21st 2014, 8:32pm)

3 333

by Wet_Boots

(Apr 27th 2014, 9:26am)

by Oscar S. Ramirez (Mar 21st 2014, 5:28pm)

1 362

by mrfixit

(Mar 22nd 2014, 1:58am)

by PerryNZ (Mar 12th 2014, 10:57pm)

5 491

by PerryNZ

(Mar 14th 2014, 12:16am)

by JT (Mar 9th 2014, 8:08pm)

1 387

by Wet_Boots

(Mar 10th 2014, 5:56pm)



480 Threads - 1,807 Posts (average 0.36 Posts per Day)