You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 378

by Wet_Boots

(Dec 26th 2012, 8:32am)

by rockypoint (Nov 26th 2012, 6:02pm)

2 514

by mrfixit

(Nov 26th 2012, 7:30pm)

by dgaines (Nov 5th 2012, 5:27pm)

3 714

by dgaines

(Nov 10th 2012, 4:15pm)

by GregM (Mar 17th 2011, 9:20am)

23 3,005

by mrfixit

(Nov 1st 2012, 9:39pm)

by Jlivengood (Oct 20th 2012, 2:01am)

3 494

by Wet_Boots

(Oct 20th 2012, 5:11pm)

by njchoochoo1 (Oct 16th 2012, 8:13pm)

3 453

by Wet_Boots

(Oct 18th 2012, 9:14am)

by ddak32@yahoo.com (Oct 17th 2012, 3:09pm)

1 437

by Wet_Boots

(Oct 17th 2012, 5:31pm)

by ragtop69 (Oct 12th 2012, 7:11pm)

1 746

by Wet_Boots

(Oct 12th 2012, 10:24pm)

by Sartenose (Sep 22nd 2012, 2:31pm)

1 457

by Wet_Boots

(Sep 22nd 2012, 10:06pm)

by diegogarcia67 (Sep 22nd 2012, 6:32pm)

0 262

No reply

Show

Statistics:

435 Threads - 1,641 Posts (average 0.36 Posts per Day)