You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by joe decoste (Mar 19th 2011, 11:56am)

1 142

by Wet_Boots

(Mar 20th 2011, 7:29am)

by clm716 (Aug 7th 2011, 9:58am)

1 143

by Central Irrigation

(Aug 7th 2011, 10:49am)

by abhnoclue (Jun 16th 2007, 10:57am)

2 143

by abhnoclue

(Jun 17th 2007, 6:20am)

by SteveM099 (Jun 15th 2006, 2:09pm)

1 144

by SteveM099

(Jun 15th 2006, 2:21pm)

by Bonelawr (Jul 29th 2012, 9:45am)

2 145

by Bonelawr

(Jul 29th 2012, 11:38am)

by Lainiest (Jul 2nd 2012, 7:11pm)

2 146

by GatorGuy

(Jul 3rd 2012, 8:00am)

by edincary (Oct 3rd 2008, 8:31pm)

1 146

by mrfixit

(Oct 3rd 2008, 11:05pm)

by lloydlevy (Nov 28th 2011, 11:14am)

3 147

by Wet_Boots

(Nov 29th 2011, 8:22am)

by shellbeach (Sep 27th 2010, 4:18pm)

2 147

by Wet_Boots

(Sep 28th 2010, 1:11pm)

by maddog (Sep 8th 2011, 5:48pm)

1 148

by grey

(Sep 9th 2011, 11:40am)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)