You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mugentuner (Aug 30th 2004, 12:30pm)

1 176

by mugentuner

(Sep 6th 2004, 8:44am)

by JT (Mar 9th 2014, 8:08pm)

1 177

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by mikem (Jan 4th 2004, 7:33pm)

0 177

No reply

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 179

No reply

by abcoker (May 9th 2014, 2:43pm)

5 180

by Wet_Boots

(May 23rd 2014, 7:04am)

by rickesco (Jul 28th 2004, 8:13am)

3 186

by aquamatic

(Jul 29th 2004, 10:36am)

by g (Apr 19th 2011, 1:56pm)

0 187

No reply

by ahersman (Sep 30th 2009, 1:37pm)

1 187

by ahersman

(Sep 30th 2009, 6:15pm)

by 0303maz (Jun 12th 2012, 9:20am)

1 190

by mrfixit

(Jun 12th 2012, 9:45am)

by joe decoste (Mar 19th 2011, 11:56am)

1 190

by Wet_Boots

(Mar 20th 2011, 7:29am)

Show

Statistics:

436 Threads - 1,654 Posts (average 0.36 Posts per Day)