You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Gremlin274 (Jun 12th 2005, 12:57pm)

1 156

by Wet_Boots

(Jun 12th 2005, 1:13pm)

by JT (Mar 9th 2014, 8:08pm)

1 159

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by mugentuner (Aug 30th 2004, 12:30pm)

1 160

by mugentuner

(Sep 6th 2004, 8:44am)

by rickesco (Jul 28th 2004, 8:13am)

3 163

by aquamatic

(Jul 29th 2004, 10:36am)

by Oscar S. Ramirez (Mar 21st 2014, 5:28pm)

1 167

by mrfixit

(Mar 22nd 2014, 1:58am)

by mikem (Jan 4th 2004, 7:33pm)

0 169

No reply

by PerryNZ (Mar 12th 2014, 10:57pm)

5 170

by PerryNZ

(Mar 14th 2014, 12:16am)

by lalloo (Aug 5th 2012, 11:02am)

2 170

by GatorGuy

(Aug 6th 2012, 9:13am)

by joe decoste (Mar 19th 2011, 11:56am)

1 171

by Wet_Boots

(Mar 20th 2011, 7:29am)

by clm716 (Aug 7th 2011, 9:58am)

1 172

by Central Irrigation

(Aug 7th 2011, 10:49am)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)