You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by svsprinklers (May 19th 2010, 9:29pm)

2 1,100

by PhoenixDen

(Jun 24th 2010, 11:27am)

by asegal (Oct 5th 2006, 7:43am)

4 1,080

by asegal

(Oct 6th 2006, 10:52am)

by bherholz (May 16th 2011, 12:06pm)

5 1,079

by mrfixit

(Jun 7th 2011, 5:46pm)

by larbec7 (Jun 6th 2009, 5:07pm)

9 1,075

by Wet_Boots

(Jun 9th 2009, 12:52pm)

by Marvel (Jan 19th 2013, 6:54am)

7 1,058

by Marvel

(Jan 22nd 2013, 7:49pm)

by lbfalgi (Aug 30th 2011, 6:15pm)

1 988

by Central Irrigation

(Aug 30th 2011, 8:38pm)

by fwoodall (Aug 28th 2005, 6:01pm)

2 980

by squints

(Jul 31st 2011, 2:16pm)

by wmhallii (Aug 4th 2005, 9:51am)

2 980

by wmhallii

(Aug 5th 2005, 4:16am)

by Caltino (Apr 12th 2013, 7:18pm)

12 971

by Wet_Boots

(Apr 27th 2013, 7:42am)

by Frankpc (Jul 22nd 2010, 9:02pm)

0 957

No reply

Show

Statistics:

457 Threads - 1,702 Posts (average 0.37 Posts per Day)