You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Buff (Jun 6th 2008, 8:25am)

6 4,458

by mrfixit

(Jun 6th 2008, 1:59pm)

by julieblades (Jan 7th 2006, 6:27am)

6 636

by Mudpuppy

(Oct 12th 2006, 6:03pm)

by Kevin Dearden (Jun 14th 2003, 4:15am)

6 760

by Rays Sprinklers

(Jul 2nd 2003, 8:52am)

by Stanman (Oct 28th 2014, 10:11pm)

5 393

by Wet_Boots

(Oct 30th 2014, 5:08am)

by abcoker (May 9th 2014, 2:43pm)

5 528

by Wet_Boots

(May 23rd 2014, 7:04am)

by PerryNZ (Mar 12th 2014, 10:57pm)

5 546

by PerryNZ

(Mar 14th 2014, 12:16am)

by beachdoc (May 19th 2012, 1:37pm)

5 1,542

by pavelow

(Oct 30th 2013, 9:51pm)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 876

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by Sierra9093 (Jul 5th 2011, 8:06pm)

5 732

by s123mith

(Jul 10th 2012, 5:21am)

by PintoDr (Jun 28th 2012, 11:50pm)

5 965

by Wet_Boots

(Jun 29th 2012, 10:15pm)

Show

Statistics:

486 Threads - 1,840 Posts (average 0.36 Posts per Day)