You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by kmofleh (Nov 3rd 2014, 4:24pm)

1 151

by kmofleh

(Nov 3rd 2014, 4:36pm)

by LT87 (May 21st 2014, 11:33am)

3 153

by hi.todd

(May 27th 2014, 1:03pm)

by donlo (Apr 18th 2006, 3:20am)

0 154

No reply

by dan2125 (Apr 10th 2004, 2:17pm)

1 154

by RVLI

(Apr 13th 2004, 5:30pm)

by noquarter (May 24th 2014, 1:22pm)

6 156

by Wet_Boots

(May 26th 2014, 6:22am)

by JAshburn (Apr 23rd 2014, 10:04pm)

3 159

by Wet_Boots

(Apr 24th 2014, 4:22pm)

by 68watford (Apr 30th 2006, 9:14am)

0 160

No reply

by lloydlevy (Nov 28th 2011, 1:34pm)

1 165

by Wet_Boots

(Nov 28th 2011, 3:46pm)

by jstanley (Aug 30th 2005, 5:37pm)

1 168

by SprinklerGuy

(Sep 6th 2005, 7:09am)

by wetyet (Apr 6th 2006, 4:16pm)

2 172

by wetyet

(Apr 7th 2006, 4:01pm)

Show

Statistics:

464 Threads - 1,709 Posts (average 0.37 Posts per Day)